Ook voor PHP geldt dat code die niet onderhouden wordt, gevoelig is voor fouten en veiligheidsproblemen. Daarom ondersteunen wij altijd de laatste versie van PHP, en wordt de ondersteuning voor oudere versies verwijderd. Zorg er dus voor dat jouw website up-to-date is. In dit artikel helpen we je op weg.

Waarom stappen we over op nieuwe versies?

De ontwikkelaars van PHP zitten niet stil. Er wordt continu doorontwikkeld aan nieuwe versies. Op de site van PHP is te vinden wat het ontwikkeltraject is, en tot wanneer welke versies ondersteund blijven.

Code die niet onderhouden wordt, is gevoelig voor fouten en veiligheidsproblemen. Om de veiligheid van ons hostingplatform en van jouw website te garanderen, moeten we dergelijke software buiten gebruik stellen. Als je dus nog gebruik maakt van een oudere PHP-versie dan is het van belang dat je ervoor zorgt dat je website overweg kan met de nieuwste PHP versie.

Gelukkig is de overstap meestal niet lastig. Meestal worden verouderde functies verwijderd en vervangen door nieuwe. Daarnaast hebben nieuwere versies vaak nieuwe mogelijkheden die de moeite van de overstap waard zijn. PHP heeft een migration guide waarin alle wijzigingen beschreven worden.

Informatie over de verschillende PHP-versies

Als je meer wilt weten over de verschillende PHP-versies dan kun je hiervoor terecht op de PHP.net website:

Per PHP-versie worden functies aangemerkt als deprecated (verouderd) en worden een versie later verwijderd. Maak je hiervan gebruik in je PHP-code, dan levert dat een nare foutmelding op. Op deze pagina op php.net vind je per versie welke functies aangemerkt worden als deprecated.

Wat kun je doen?

Het beste advies wat wij je kunnen geven is om je website uit te testen met de nieuwste versie. Dat kan op je eigen computer, op een test-server of bij de bouwer van je website. Hierbij is het handig om het tonen van foutmeldingen aan te zetten op je site.

Je kunt ook contact opnemen met onze klantenservice om op ons platform uit te testen welke wijzigingen aan je website nodig zijn. Het is goed mogelijk dat jouw site zonder aanpassingen werkt met de nieuwste versie van PHP, zeker als je een modern pakket als WordPress gebruikt.

Welke versie van mijn CMS moet ik gebruiken?

Van de meest bekende CMS pakketten zijn vele versies in omloop. Maar welke versie moet je nu minimaal hebben om gebruik te kunnen maken van PHP 7? De onderstaande versies zijn de minimale vereiste zodat je PHP 7 kunt gebruiken. In alle gevallen raden we je aan om de meest recente versie van je CMS te installeren.

    • Joomla!
      Als je gebruik maakt van Joomla! zorg er dan voor dat je minimaal versie 3.5 hebt geïnstalleerd. Deze versie zorgt voor ondersteuning van PHP 7.
    • WordPress
      Van WordPress heb je minimaal versie 4.4 nodig. Let wel op: wellicht kan je thema of een gebruikte plugin (nog) niet overweg met PHP 7.
    • Drupal
      Vanaf Drupal versie 8 is er in dit pakket ondersteuning voor PHP 7.
    • CMS Made Simple
      Zorg voor minimaal versie 1.12.1 van dit pakket om gebruik te kunnen maken van PHP 7.

Wat vond je van dit antwoord?

Bedankt voor je feedback!

Er is een fout opgetreden. Probeer het later opnieuw.