PHP

Let op: Converteer PHP MySQL naar MySQLi voor het te laat is

Gebruik jij nog verouderde MySQL-functies zoals mysql_connect(), de zogenoemde ext/mysql extensie? Let dan goed op! PHP stopt met de ondersteuning hiervan. Als jij wilt dat jouw website blijft functioneren met nieuwe ‪PHP-versies, moet je nu overstappen naar MySQLi (of PHP Data Objects / PDO). Onze Jan Reilink legt uit hoe je dit voor elkaar krijgt.

MySQL-databasetoegang met PHP en PDO

Dit artikel legt uit hoe je een verbinding maakt met MySQL vanuit PHP 7.1+ en PHP Data Objects (PDO). Met PHP 7.1 en hoger kun je over een SSL-beveiligde verbinding jouw MySQL-database benaderen. Hier een eenvoudig voorbeeld.

PHP bij Vevida

Je wilt graag gebruik maken van PHP op jouw website? Uiteraard kun je bij Vevida standaard gebruik maken van PHP. PHP staat voor PHP: Hypertext Preprocessor en is de meest gebruikte scripttaal voor het web. Het doel van PHP is om webdevelopers snel dynamisch gegenereerde pagina’s te laten schrijven.

PHP en de default_charset

Weergave van speciale tekens in PHP

Als je gebruikmaakt van speciale tekens op je site dan kan het zijn dat dit sinds de introductie van PHP 5.6 niet meer werkt. Dit komt door een wijziging van de waarde van de default_charset variabele in php.ini. Deze was standaard leeg, maar staat sinds PHP 5.6 ingesteld op UTF-8.

PHP foutmeldingen tonen

Het weergeven en/of opslaan van PHP-foutmeldingen is handig voor het debuggen van je website en problemene. Je kunt PHP foutmeldingen bekijken die veroorzaakt worden door fouten in de PHP code. Standaard staat dit weergeven ervan uitgeschakeld, met een simpele wijziging kun je PHP foutmeldingen tonen op je website.

PHP migreren naar nieuwere versies

Ook voor PHP geldt dat code die niet onderhouden wordt, gevoelig is voor fouten en veiligheidsproblemen. Daarom ondersteunen wij altijd de laatste versie van PHP, en wordt de ondersteuning voor oudere versies verwijderd. Zorg er dus voor dat jouw website up-to-date is. In dit artikel helpen we je op weg.

Welke PHP-versie moet ik gebruiken?

Als jouw website gebruik maakt van PHP, zoals bijv. een WordPress website, dan is het van groot belang om deze altijd bij te werken naar de meest recente PHP-versie (zie infographic). Dit zorgt voor een betere prestatie en voorkomt dat je website straks niet meer werkt.

Klantenservice

Niet gevonden wat je zocht? Neem contact op met onze klantenservice:

We zijn je graag van dienst.